Linux version not loading

Discussion in 'System Shock 2' started by Stewart Little, Jan 9, 2018.

  1. Stewart Little

    Stewart Little New Member

    Joined:
    Jan 9, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Hi!

    I had a look on the web for the original creator for the game system shock 2 but they were made obsolete so I'm contacting NightDive since you are the publisher.

    I'm having problems with the game System shock 2 on Linux with the open source AMD drivers it states when I clicked on the play button "running" but then the running bit disappears on steam and then nothing happens, no error messages, no window popups nothing. Could Nightdive if possible fix this problem? I did click on Report product icon on the store page and reported it as broken but heard nothing back. My system is using the AMD FX-8350 processor with the AMD Radeon R7 370 graphics card 2GB it should run it but it doesn't.

    I would love to play this classic game but can't due to the current problem! Can any developer for Nightdive assist?
     
  2. Shaun Gupta

    Shaun Gupta Moderator Staff Member

    Joined:
    Oct 18, 2016
    Messages:
    43
    Likes Received:
    22
    Trophy Points:
    8
    Gender:
    Male
    Andre likes this.
  3. Andre

    Andre Moderator Staff Member

    Joined:
    Mar 21, 2017
    Messages:
    23
    Likes Received:
    7
    Trophy Points:
    3
    Hi Stewart try this fix. It sounds like this is what is happening with you.
    https://steamcommunity.com/app/238210/discussions/0/558752451322338339/

    "In cam_ext.cfg disable D3D Display by changing line to read ;use_d3d_display
    The simi-colon prefix hides/disables the command line."

    also this fix is reported to work.

    "Forcing the game to windowed mode seems to work. Just un comment the line "force_windowed" to play."

    I use Linux quite a bit but dont game on linux a lot so dont have a lot of direct experience with your issue. Hopefully they help.
     
    Shaun Gupta likes this.
  4. Andre

    Andre Moderator Staff Member

    Joined:
    Mar 21, 2017
    Messages:
    23
    Likes Received:
    7
    Trophy Points:
    3
    haha. this is what happens when two moderators talk to each other behind the scenes but actually have no idea what the other one is going to do. :p
     
    Last edited: Jan 9, 2018
    Shaun Gupta likes this.
  5. Andre

    Andre Moderator Staff Member

    Joined:
    Mar 21, 2017
    Messages:
    23
    Likes Received:
    7
    Trophy Points:
    3
    You also might need to adjust the cam.cfg resolution.

    "I found cam.cfg and edited game_screen_size 1024 768 and verified game_full_screen 1"
     
  6. Stewart Little

    Stewart Little New Member

    Joined:
    Jan 9, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Hi! I've unfortunately tried all of those and nothing happens even the windowed mode and it still does the same problem.
     
  7. Andre

    Andre Moderator Staff Member

    Joined:
    Mar 21, 2017
    Messages:
    23
    Likes Received:
    7
    Trophy Points:
    3
    HI Stewart. I am not sure what the issue is. I may fire up my laptop running linux and see if I can duplicate it. The problem is that I am using a different Linux OS then you, presumably, and my laptop has an intel cpu and a nvidia gpu. Also, I am not using any proprietary drivers.

    So, the results would not be conclusive. Night Dive Studios is now aware of the issue and looking into it. In the mean time, if you find a solution please share it here. If I come up with a fix or find another persons solution I will post it here as well.

    Cheers

    :)
     

Share This Page